Activate via URL parameter not working – PickPlugins

Activate via URL parameter not working

OTM
Jun 21, 2018 06:52 PM 1 Answers General
Member Since May 2018
Subscribed Subscribe Not subscribe
Flag(0)
The accordion will open to the correct level if I use ?target=accordion+tab&id=11, but if I try to add the argument to navigate the screen to the correct level ?target=accordion+tab&id=11#id-11 then nothing happens. The accordion still opens the correct level but the page does not scroll down. I have also tried ?target=accordion+tab&id=11#ui-id-11 as your FAQ page is not clear which should work, but this also does not work. https://www.pickplugins.com/documentation/accordions/faq/how-to-openactivate-via-url-parameter/ If needed: https://otmplcprod.staging.wpengine.com/policies/?target=privacy+policy&id=11#id-11
2 Subscribers
Submit Answer
Please login to submit answer.

1 Answers
Sort By:
Best Answer
0
PickPlugins
Jun 21, 2018
Flag(0)

Welcome to our forum.

I am not sure where did you find the  ?target= parameter, this will not work.

Open via URL Parameter

You should start from 0 (“zero” top to bottom) which header you want to keep activate, and add #id to scroll down where you want to scroll on load.

Please see the attachment how to find # id

View post on imgur.com

Regards

OTM
- Jun 21, 2018 07:37 PM
Flag (0)
0

Hi,

The Accordion is within a tab, so the ?target= determines which tab to open first and then which Accordion level to open.

Trying this on your page, http://www.pickplugins.com/demo/accordions/open-via-url-parameter/?id=5#id-1453438414115, should open and scroll to the final accordion. It does open but it does not scroll?

OTM
- Jun 21, 2018 07:41 PM
Flag (0)
0

Ah, I see there is the ui-id in there too. It is working now, thanks.

Sign in to Reply
Replying as Submit